CVE-2024-49757 — zitadel
HIGHCVE-2024-49757 is a high-severity (CVSS 7.5) Improper Authentication vulnerability in github.com/zitadel/zitadel. A fix is available for github.com/zitadel/zitadel — see the affected versions and patch details below.
Zitadel User Registration Bypass Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-49757.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadelReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Zitadel allows administrators to disable the user self-registration. Due to a missing security check in versions prior to 2.63.4, disabling the "User Registration allowed" option only hid the registration button on the login page. Users could bypass this restriction by directly accessing the registration URL (/ui/login/loginname) and register a user that way.
Patches
2.x versions are fixed on >= 2.64.0 2.63.x versions are fixed on >= 2.63.5 2.62.x versions are fixed on >= 2.62.7 2.61.x versions are fixed on >= 2.61.4 2.60.x versions are fixed on >= 2.60.4 2.59.x versions are fixed on >= 2.59.5 2.58.x versions are fixed on >= 2.58.7
Workarounds
Updating to the patched version is the recommended solution.
Questions
If you have any questions or comments about this advisory, please email us at [email protected]
Credits
Thanks to @sevensolutions and @evilgensec for disclosing this!
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.63.0&&< 2.63.5 | 2.63.5go get github.com/zitadel/zitadel@v2.63.5 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.62.0&&< 2.62.7 | 2.62.7go get github.com/zitadel/zitadel@v2.62.7 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.61.0&&< 2.61.4 | 2.61.4go get github.com/zitadel/zitadel@v2.61.4 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.60.0&&< 2.60.4 | 2.60.4go get github.com/zitadel/zitadel@v2.60.4 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.59.0&&< 2.59.5 | 2.59.5go get github.com/zitadel/zitadel@v2.59.5 |
| 🐹Go | github.com/zitadel/zitadel | all versions | 2.58.7go get github.com/zitadel/zitadel@v2.58.7 |
Affected Products
zitadelzitadelDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/zitadel/zitadel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/zitadel/zitadel to 2.63.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-49757 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2024-49757
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-49757 -u https://target- Template
- Zitadel - User Registration Bypass
- Severity
- high
- Impact
- Unauthenticated users can bypass the disabled user registration restriction and register accounts.
- Remediation
- Update Zitadel to version 2.64.0, 2.63.5, 2.62.7, 2.61.4, 2.60.4, 2.59.5, or 2.58.7 or later.
Template by ProjectDiscovery nuclei-templates (Sujal Tuladhar), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-49757 in your dependencies?
Find it across Go, including transitive dependencies.