NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💧
💧 Hex
Not in CISA KEV
MEDIUM severity

CVE-2024-49756 — ash_postgres

MEDIUMFix: ash-project/ash_postgres@1228fcd

CVE-2024-49756 is a medium-severity (CVSS 5.3) CWE-552 vulnerability in ash_postgres. A fix is available for ash_postgres — see the affected versions and patch details below.

AshPostgres empty, atomic, non-bulk actions, policy bypass for side-effects vulnerability.

Also known asGHSA-hf59-7rwq-785m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-49756.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.67%1.01%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💧ash_postgres

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex packages — download data is not available via public APIs for these ecosystems.

Description

Impact

What kind of vulnerability is it? Who is impacted?

In certain very specific situations, it was possible for the policies of an update action to be skipped. This occurred only on "empty" update actions (no changing fields), and would allow their hooks (side effects) to be performed when they should not have been. Note that this does not allow reading new data that the user should not have had access to, only triggering a side effect a user should not have been able to trigger.

You must have an update action that:

  • Is on a resource with no attributes containing an "update default" (updated_at timestamp, for example)
  • can be performed atomically.
  • Does not have require_atomic? false
  • Has at least one authorizer (typically Ash.Policy.Authorizer)
  • Has at least one change (on the resource's changes block or in the action itself) This is where the side-effects would be performed when they should not have been.

  • Is there ever a place where you call this action manually, using Ash.update. Note that AshGraphql and AshJsonApi action calls are not affected as they use Ash.bulk_update.
  • If so, is there ever a case where you call the action with zero inputs, and have it produce zero changing fields.
  • If so, could it then produce a side effect. This means you'd have an after_action hook that calls some other resource.
  • If so, does that side effect bypass another resource's policies, i.e using authorize?: false, or not providing the same actor.

Everything above the line can be checked with the provided script. Everything below it, must be checked manually. The script for checking this is available in the "Might I be affected" section.

The script can have false positives, but will not have any false negatives. So if you run the script, and it says "No potential vulnerabilities found", then all you need to do is update ash_postgres.

Patches

This problem has been patched in 2.4.10 of ash_postgres.

Workarounds

You could:

  1. Determine that none of your actions are vulnerable using the script.
  2. Add require_atomic? false to any potentially affected update action
  3. Replace any usage of Ash.update with Ash.bulk_update for an affected action
  4. add an update timestamp to your action.

Might I be affected

This gist provides a script you can run to detect if you are potentially vulnerable.

https://gist.github.com/zachdaniel/e49166b765978c48dfaf998d06df436e

References

Original Report/discovery: https://elixirforum.com/t/empty-update-action-with-policies/66954 Fix commit: https://github.com/ash-project/ash_postgres/commit/1228fcd851f29a68609e236f7d6a2622a4b5c4ba

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💧Hexash_postgres≥ 2.0.0&&< 2.4.102.4.10mix deps.update ash_postgres

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ash_postgres, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ash_postgres to 2.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-49756 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact _What kind of vulnerability is it? Who is impacted?_ In certain *very specific* situations, it was possible for the policies of an update action to be skipped. This occurred only on "empty" update actions (no changing fields), and would allow their hooks (side effects) to be performed when they should not have been. Note that this does not allow reading new data that the user should not have had access to, only triggering a side effect a user should not have been able to trigger. You must have an update action that: - Is on a resource with no attributes containing an "update defa
O3 Security · Impact-Aware SCA

Is CVE-2024-49756 in your dependencies?

Find it across Hex, including transitive dependencies.

CVE-2024-49756: ash_postgres — Fixed in 2.4.10