CVE-2024-49755 is a low-severity (CVSS 3.1) Improper Authentication vulnerability in Duende.IdentityServer. A fix is available for Duende.IdentityServer — see the affected versions and patch details below.
Duende IdentityServer has insufficient validation of DPoP cnf claim in Local APIs
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-49755.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Duende.IdentityServerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
IdentityServer's local API authentication handler performs insufficient validation of the cnf claim in DPoP access tokens. This allows an attacker to use leaked DPoP access tokens at local api endpoints even without possessing the private key for signing proof tokens.
Note that this only impacts custom endpoints within an IdentityServer implementation that have explicitly used the LocalApiAuthenticationHandler for authentication. It does not impact:
- OAuth or OIDC protocol endpoints defined by IdentityServer, such as the authorize and token endpoints.
- Typical UI pages within an IdentityServer implementation, which are not normally authorized with the local API authentication handler.
- The use of DPoP to create sender-constrained tokens in IdentityServer that are consumed by external API resources.
- The use of DPoP to sender-constrain refresh tokens issued to public clients.
Are you affected?
This vulnerability only affects IdentityServer implementations that are using the local APIs feature of IdentityServer and have explicitly enabled DPoP for local APIs. The local api authentication handler is configured with a call to either AddLocalApi or AddLocalApiAuthentication, and the opt-in to DPoP for local APIs is enabled via the TokenMode option.
Vulnerable implementations of IdentityServer would have configuration code similar to the following:
services.AddAuthentication()
.AddLocalApi("local", options =>
{
options.TokenMode = LocalApiTokenMode.DPoPAndBearer; // or LocalApiTokenMode.DPoPOnly
});
Patches
This vulnerability is patched in IdentityServer 7.0.8. Version 6.3 and below are unaffected, as they do not support DPoP in Local APIs.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Duende.IdentityServer | ≥ 7.0.0&&< 7.0.8 | 7.0.8dotnet add package Duende.IdentityServer --version 7.0.8 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Duende.IdentityServer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Duende.IdentityServer to 7.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-49755 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-49755 in your dependencies?
Find it across NuGet, including transitive dependencies.