NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2024-47178 — basic-auth-connect

Fix: expressjs/basic-auth-connect@bac1e6a

CVE-2024-47178 is a CWE-208 vulnerability in basic-auth-connect. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for basic-auth-connect — see the affected versions and patch details below.

basic-auth-connect's callback uses time unsafe string comparison

Also known asGHSA-7p89-p6hx-q4fw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47178.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.68%1.02%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

128other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
basic-auth-connectnpm
4.3Mdownloads / week

Description

basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmbasic-auth-connectall versions1.1.0npm install basic-auth-connect@1.1.0

Affected Products

1 product · 1 configurations
Application
basic-auth-connectexpressjs
< 1.1.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for basic-auth-connect, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update basic-auth-connect to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47178 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat Fuse 7 will reach the end of maintenance support in June 2024. For More Info Please Visit: https://access.redhat.com/announcements/7023424 https://access.redhat.com/support/policy/updates/jboss_notes

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-47178 (CC BY 4.0)

Frequently Asked Questions

basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.
O3 Security · Impact-Aware SCA

Is CVE-2024-47178 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-47178: basic-auth Info Disclosure — Fixed in 1.1.0