NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-47173 — ai-admin-graphql

MEDIUM

CVE-2024-47173 is a medium-severity (CVSS 5.5) CWE-270 vulnerability in aimeos/ai-admin-graphql. A fix is available for aimeos/ai-admin-graphql — see the affected versions and patch details below.

Aimeos GraphQL API admin interface denial of service vulnerability in SaaS and marketplace setups

Also known asGHSA-qxgx-hvg3-v92w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47173.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs30th percentile — riskier than 30% of all scored CVEsHighest risk
0.00%0.29%0.57%0.86%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘aimeos/ai-admin-graphql

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Aimeos is an e-commerce framework. All SaaS and marketplace setups using the Aimeos GraphQL API admin interface version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack. Version 2024.07.2 fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistaimeos/ai-admin-graphql≥ 2024.04.1&&< 2024.07.22024.07.2composer require aimeos/ai-admin-graphql:^2024.07.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aimeos/ai-admin-graphql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aimeos/ai-admin-graphql to 2024.07.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47173 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Aimeos is an e-commerce framework. All SaaS and marketplace setups using the Aimeos GraphQL API admin interface version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack. Version 2024.07.2 fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2024-47173 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-47173: ai-admin DoS — Fixed in 2024.07.2