CVE-2024-45803 — wireui
Fix: wireui/wireui@784c4f1CVE-2024-45803 is a Cross-site Scripting (XSS) vulnerability in wireui/wireui. A fix is available for wireui/wireui — see the affected versions and patch details below.
Cross site scripting (XSS) Vulnerability on route /wireui/button?label=Content in wireui
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45803.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
wireui/wireui🐘wireui/wireuiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A potential Cross-Site Scripting (XSS) vulnerability has been identified in the /wireui/button endpoint, specifically through the label query parameter. Malicious actors could exploit this vulnerability by injecting JavaScript into the label parameter, leading to the execution of arbitrary code in the victim's browser.
Details
The /wireui/button endpoint dynamically renders button labels based on user-provided input via the label query parameter. Due to insufficient sanitization or escaping of this input, an attacker can inject malicious JavaScript. The following URL demonstrates the vulnerability:
https://wireui.dev/wireui/button?label=Cancel&1%25%7ds8dk0%3E%3Cscript%3Ealert(1)%3C/script%3Ez1qt3=1
By crafting such a request, an attacker can inject arbitrary code that will be executed by the browser when the endpoint is accessed.
Proof of Concept (PoC)
To demonstrate the vulnerability, visit the following URL:
/wireui/button?label=<script>alert(1)</script>
Upon loading the page, the injected JavaScript will execute, displaying an alert with the message "1." This confirms the vulnerability and highlights that user input is not being properly escaped or sanitized.
Impact
If exploited, this vulnerability could allow an attacker to execute arbitrary JavaScript code in the context of the affected website. This could lead to:
- Session Hijacking: Stealing session cookies, tokens, or other sensitive information.
- User Impersonation: Performing unauthorized actions on behalf of authenticated users.
- Phishing: Redirecting users to malicious websites.
- Content Manipulation: Altering the appearance or behavior of the affected page to mislead users or execute further attacks.
The severity of this vulnerability depends on the context of where the affected component is used, but in all cases, it poses a significant risk to user security.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | wireui/wireui | all versions | 1.19.3composer require wireui/wireui:^1.19.3 |
| 🐘Packagist | wireui/wireui | ≥ 2.0.0&&< 2.1.3 | 2.1.3composer require wireui/wireui:^2.1.3 |
Affected Products
wireuiwireuiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wireui/wireui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wireui/wireui to 1.19.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45803 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-45803 in your dependencies?
Find it across Packagist, including transitive dependencies.