CVE-2024-45690 is a high-severity (CVSS 7.5) Incorrect Default Permissions vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle: idor when deleting oauth2 linked accounts
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45690.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 4.1.13composer require moodle/moodle:^4.1.13 |
| 🐘Packagist | moodle/moodle | ≥ 4.2.0-beta&&< 4.2.10 | 4.2.10composer require moodle/moodle:^4.2.10 |
| 🐘Packagist | moodle/moodle | ≥ 4.3.0-beta&&< 4.3.7 | 4.3.7composer require moodle/moodle:^4.3.7 |
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.3 | 4.4.3composer require moodle/moodle:^4.4.3 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.1.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45690 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2024-45690 in your dependencies?
Find it across Packagist, including transitive dependencies.