NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🛡️
Not in CISA KEV
HIGH severity

CVE-2024-45507 — ofbiz-framework

HIGH

CVE-2024-45507 is a high-severity (CVSS 8.8) Code Injection vulnerability. EPSS puts its 30-day exploitation probability at 96.4% (100th percentile). A fix is available — see the affected versions and patch details below.

Apache OFBiz: Prevent use of URLs in files when loading them from Java or Groovy, leading to a RCE

Published
Updated
Affected
1 product
Patched
See advisory
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45507.

EPSS Exploitation Probability

via FIRST.org ↗
96.4%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
87.5%91.1%94.8%98.4%89.5%96.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Description

Server-Side Request Forgery (SSRF), Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz.

This issue affects Apache OFBiz: before 18.12.16.

Users are recommended to upgrade to version 18.12.16, which fixes the issue.

Affected Products

1 product · 1 configurations
Application
ofbizapache
< 18.12.16
range

Detection & mitigation playbook

Vulnerability
  1. Detect

    Identify every host running the affected component and compare the installed build against the fixed version below — for source-built or distro-packaged software the version string, not a lockfile, is the source of truth (`dpkg -l`, `rpm -q`, or the binary's own `--version`).

  2. Fix

    Upgrade the affected component to the fixed release for CVE-2024-45507, or apply your distribution's backported patch — distro builds are often patched at an older version number, so check your vendor's advisory rather than the upstream version alone.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2024-45507

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-45507 -u https://target
Template
Apache OFBiz - Remote Code Execution
Severity
critical
Impact
Unauthenticated attackers can exploit missing view authorization checks to execute arbitrary code on Apache OFBiz servers.
Remediation
Users are recommended to upgrade to version 18.12.16, which fixes the issue.

Template by ProjectDiscovery nuclei-templates (chybeta, iamnooob, rootxharsh), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Server-Side Request Forgery (SSRF), Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 18.12.16. Users are recommended to upgrade to version 18.12.16, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2024-45507 in your dependencies?

Find it across your dependency tree, including transitive dependencies.

CVE-2024-45507: ofbiz-framework RCE (High 8.8)