CVE-2024-45120 — community-edition
LOWCVE-2024-45120 is a low-severity (CVSS 3.1) CWE-367 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Adobe Commerce | Time-of-check Time-of-use (TOCTOU) Race Condition (CWE-367)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45120.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by a Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability that could lead to a security feature bypass. An attacker could exploit this vulnerability to alter a condition between the check and the use of a resource, having a low impact on integrity. Exploitation of this issue requires user interaction.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.4.7-beta1&&< 2.4.7-p3 | 2.4.7-p3composer require magento/community-edition:^2.4.7-p3 |
| 🐘Packagist | magento/community-edition | ≥ 2.4.6-p1&&< 2.4.6-p8 | 2.4.6-p8composer require magento/community-edition:^2.4.6-p8 |
| 🐘Packagist | magento/community-edition | ≥ 2.4.5-p1&&< 2.4.5-p10 | 2.4.5-p10composer require magento/community-edition:^2.4.5-p10 |
| 🐘Packagist | magento/community-edition | all versions | 2.4.4-p11composer require magento/community-edition:^2.4.4-p11 |
| 🐘Packagist | magento/community-edition | all versions | No fix |
| 🐘Packagist | magento/community-edition | all versions | No fix |
Affected Products
commerceadobecommerce b2badobemagentoadobeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.4.7-p3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45120 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-45120 in your dependencies?
Find it across Packagist, including transitive dependencies.