CVE-2024-44906 is a medium-severity (CVSS 6.5) SQL Injection vulnerability in github.com/uptrace/bun/driver/pgdriver. A fix is available for github.com/uptrace/bun/driver/pgdriver — see the affected versions and patch details below.
uptrace pgdriver SQL injection vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-44906.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/uptrace/bun/driver/pgdriverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
uptrace pgdriver v1.2.1 was discovered to contain a SQL injection vulnerability via the appendArg function in /pgdriver/format.go. The maintainer has stated that the issue is fixed in v1.2.15.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/uptrace/bun/driver/pgdriver | all versions | 1.2.15go get github.com/uptrace/bun/driver/pgdriver@v1.2.15 |
Affected Products
pgdriveruptraceDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/uptrace/bun/driver/pgdriver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/uptrace/bun/driver/pgdriver to 1.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-44906 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2024-44906 in your dependencies?
Find it across Go, including transitive dependencies.