NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2024-43800 — serve-static

MEDIUMFix: expressjs/serve-static@0c11fad

CVE-2024-43800 is a medium-severity (CVSS 5) Cross-site Scripting (XSS) vulnerability in serve-static. A fix is available for serve-static — see the affected versions and patch details below.

serve-static affected by template injection that can lead to XSS

Also known asGHSA-cm22-4g7w-348p
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43800.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.10%0.55%1.00%1.45%0.9%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

4Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
serve-staticnpm
202.2Mdownloads / week

Description

Impact

passing untrusted user input - even after sanitizing it - to redirect() may execute untrusted code

Patches

this issue is patched in serve-static 1.16.0

Workarounds

users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist

Details

successful exploitation of this vector requires the following:

  1. The attacker MUST control the input to response.redirect()
  2. express MUST NOT redirect before the template appears
  3. the browser MUST NOT complete redirection before:
  4. the user MUST click on the link in the template

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmserve-staticall versions1.16.0npm install serve-static@1.16.0
📦npmserve-static≥ 2.0.0&&< 2.1.02.1.0npm install serve-static@2.1.0

Affected Products

1 product · 2 configurations
Application
serve-staticopenjsf
≥ 2.0.0 && < 2.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for serve-static, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update serve-static to 1.16.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43800 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

rhdh-hub-container 1.2 and 1.3 have included patches for this vulnerability.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-43800 (CC BY 4.0)
ProductFixed inAdvisory
Discovery 1 for RHEL 9discovery/discovery-server-rhel9:1.12.0-1RHSA-2025:1249
HawtIO 4.0.0 for Red Hat build of Apache Camel 4serve-staticRHSA-2024:11023
NETWORK-OBSERVABILITY-1.7.0-RHEL-9network-observability/network-observability-cli-rhel9:v1.7.0-67RHSA-2024:8014
Red Hat Developer Hub 1.3 on RHEL 9rhdh/rhdh-hub-rhel9:1.3-100RHBA-2024:7523
Red Hat Migration Toolkit for Containers 1.8rhmtc/openshift-migration-ui-rhel8:v1.8.5-7RHSA-2024:10906
Red Hat OpenShift Container Platform 4.17openshift4/nmstate-console-plugin-rhel9:v4.17.0-202501301204.p0.gcffdc60.assembly.stream.el9RHSA-2025:0875
Red Hat OpenShift GitOps 1.12openshift-gitops-1/argocd-rhel8:v1.12.6-2RHSA-2024:8677
Red Hat OpenShift GitOps 1.13openshift-gitops-1/argocd-rhel8:v1.13.2-4RHSA-2024:8581

Frequently Asked Questions

### Impact passing untrusted user input - even after sanitizing it - to `redirect()` may execute untrusted code ### Patches this issue is patched in serve-static 1.16.0 ### Workarounds users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist ### Details successful exploitation of this vector requires the following: 1. The attacker MUST control the input to response.redirect() 1. express MUST NOT redirect before the template appears 1.
O3 Security · Impact-Aware SCA

Is CVE-2024-43800 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-43800: serve-static — Fixed in 1.16.0