CVE-2024-43799 is a medium-severity (CVSS 5) Cross-site Scripting (XSS) vulnerability in send. A fix is available for send — see the affected versions and patch details below.
send vulnerable to template injection that can lead to XSS
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43799.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
sendnpmDescription
Impact
passing untrusted user input - even after sanitizing it - to SendStream.redirect() may execute untrusted code
Patches
this issue is patched in send 0.19.0
Workarounds
users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist
Details
successful exploitation of this vector requires the following:
- The attacker MUST control the input to response.redirect()
- express MUST NOT redirect before the template appears
- the browser MUST NOT complete redirection before:
- the user MUST click on the link in the template
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | send | all versions | 0.19.0npm install send@0.19.0 |
Affected Products
sendsend_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for send, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update send to 0.19.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43799 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-43799 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.12.0-1 | RHSA-2025:1249 |
| HawtIO 4.0.0 for Red Hat build of Apache Camel 4 | send | RHSA-2024:11023 |
| NETWORK-OBSERVABILITY-1.7.0-RHEL-9 | network-observability/network-observability-cli-rhel9:v1.7.0-67 | RHSA-2024:8014 |
| Red Hat Developer Hub 1.2 on RHEL 9 | rhdh/rhdh-hub-rhel9:1.2-154 | RHBA-2024:10184 |
| Red Hat Migration Toolkit for Containers 1.8 | rhmtc/openshift-migration-ui-rhel8:v1.8.5-7 | RHSA-2024:10906 |
| Red Hat OpenShift Container Platform 4.17 | openshift4/nmstate-console-plugin-rhel9:v4.17.0-202501301204.p0.gcffdc60.assembly.stream.el9 | RHSA-2025:0875 |
| Red Hat OpenShift GitOps 1.12 | openshift-gitops-1/argocd-rhel8:v1.12.6-2 | RHSA-2024:8677 |
| Red Hat OpenShift GitOps 1.13 | openshift-gitops-1/argocd-rhel8:v1.13.2-4 | RHSA-2024:8581 |
Frequently Asked Questions
Is CVE-2024-43799 in your dependencies?
Find it across npm, including transitive dependencies.