CVE-2024-43791 — request_store
HIGHCVE-2024-43791 is a high-severity (CVSS 7.8) Incorrect Default Permissions vulnerability in request_store. A fix is available for request_store — see the affected versions and patch details below.
RequestStore has Incorrect Default Permissions
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43791.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
request_storeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The files published as part of request_store 1.3.2 have 0666 permissions, meaning that they are world-writable, which allows local users to execute arbitrary code.
This version was published in 2017, and most production environments do not allow access for local users, so the chances of this being exploited are very low, given that the vast majority of users will have upgraded, and those that have not, if any, are not likely to be exposed.
Patches
I am not aware of any other version of the gem with incorrect permissions, so simply upgrading should fix the issue.
Workarounds
You could chmod the files yourself, I guess.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | request_store | ≥ 1.3.2&&< 1.4.0 | 1.4.0bundle update request_store --conservative |
Affected Products
request storesteveklabnikDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for request_store, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update request_store to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43791 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2024-43791 in your dependencies?
Find it across RubyGems, including transitive dependencies.