NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-43598 — lightgbm

HIGH

CVE-2024-43598 is a high-severity (CVSS 8.1) CWE-122 vulnerability in lightgbm. A fix is available for lightgbm — see the affected versions and patch details below.

LightGBM Remote Code Execution Vulnerability

Also known asPYSEC-2024-231
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43598.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.88%1.38%1.88%2.38%1.7%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍lightgbm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

LightGBM Remote Code Execution Vulnerability

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIlightgbm≥ 1.0.0&&< 4.6.04.6.0pip install --upgrade 'lightgbm==4.6.0'

Affected Products

1 product · 1 configurations
Application
lightgbmmicrosoft
< 4.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lightgbm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update lightgbm to 4.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43598 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

LightGBM Remote Code Execution Vulnerability
O3 Security · Impact-Aware SCA

Is CVE-2024-43598 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-43598: lightgbm RCE — Fixed in 4.6.0