CVE-2024-43441 is a critical-severity (CVSS 9.8) CWE-302 vulnerability in org.apache.hugegraph:hugegraph-server. EPSS puts its 30-day exploitation probability at 73.1% (99th percentile). A fix is available for org.apache.hugegraph:hugegraph-server — see the affected versions and patch details below.
Apache HugeGraph-Server: Fixed JWT Token(Secret)
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43441.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hugegraph:hugegraph-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Authentication Bypass by Assumed-Immutable Data vulnerability in Apache HugeGraph-Server.
This issue affects Apache HugeGraph-Server: from 1.0.0 before 1.5.0.
Users are recommended to upgrade to version 1.5.0, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hugegraph:hugegraph-server | ≥ 1.0.0&&< 1.5.0 | 1.5.0org.apache.hugegraph:hugegraph-server:1.5.0 |
Affected Products
hugegraphapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hugegraph:hugegraph-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hugegraph:hugegraph-server to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43441 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2024-43441
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-43441 -u https://target- Template
- Apache HugeGraph-Server <1.5.0 - Authentication Bypass
- Severity
- critical
- Impact
- Attackers can bypass authentication, gaining unauthorized access to sensitive data or functionalities.
- Remediation
- Upgrade to Apache HugeGraph-Server version 1.5.0 or later.
Template by ProjectDiscovery nuclei-templates (wn147), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-43441 in your dependencies?
Find it across Maven, including transitive dependencies.