CVE-2024-43440 — moodle
HIGHCVE-2024-43440 is a high-severity (CVSS 7.5) Path Traversal vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle: lfi vulnerability when restoring malformed block backups
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43440.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in moodle. A local file may include risks when restoring block backups.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 4.1.12composer require moodle/moodle:^4.1.12 |
| 🐘Packagist | moodle/moodle | ≥ 4.2.0-beta&&< 4.2.9 | 4.2.9composer require moodle/moodle:^4.2.9 |
| 🐘Packagist | moodle/moodle | ≥ 4.3.0-beta&&< 4.3.6 | 4.3.6composer require moodle/moodle:^4.3.6 |
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.2 | 4.4.2composer require moodle/moodle:^4.4.2 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43440 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2024-43440 in your dependencies?
Find it across Packagist, including transitive dependencies.