NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2024-43436 — moodle

HIGH

CVE-2024-43436 is a high-severity (CVSS 7.2) SQL Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle: site administration sql injection via xmldb editor

Also known asBIT-moodle-2024-43436GHSA-mx26-62xm-2p83
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43436.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.43%0.86%1.30%0.5%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A SQL injection risk flaw was found in the XMLDB editor tool available to site administrators.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versions4.1.12composer require moodle/moodle:^4.1.12
🐘Packagistmoodle/moodle≥ 4.2.0-beta&&< 4.2.94.2.9composer require moodle/moodle:^4.2.9
🐘Packagistmoodle/moodle≥ 4.3.0-beta&&< 4.3.64.3.6composer require moodle/moodle:^4.3.6
🐘Packagistmoodle/moodle≥ 4.4.0-beta&&< 4.4.24.4.2composer require moodle/moodle:^4.4.2

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 4.4.0 && < 4.4.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43436 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

A SQL injection risk flaw was found in the XMLDB editor tool available to site administrators.
O3 Security · Impact-Aware SCA

Is CVE-2024-43436 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-43436: moodle SQL Injection — Fixed in 4.1.12