CVE-2024-43425 — moodle
HIGHCVE-2024-43425 is a high-severity (CVSS 8.1) Code Injection vulnerability in moodle/moodle. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle: remote code execution via calculated question types
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43425.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 4.1.12composer require moodle/moodle:^4.1.12 |
| 🐘Packagist | moodle/moodle | ≥ 4.2.0-beta&&< 4.2.9 | 4.2.9composer require moodle/moodle:^4.2.9 |
| 🐘Packagist | moodle/moodle | ≥ 4.3.0-beta&&< 4.3.6 | 4.3.6composer require moodle/moodle:^4.3.6 |
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.2 | 4.4.2composer require moodle/moodle:^4.4.2 |
Affected Products
moodlemoodleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Moodle 4.4.0 - Authenticated Remote Code Execution
by Likhith Appalaneni · Jul 2, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43425 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
How to detect CVE-2024-43425
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-43425 -u https://target- Template
- Moodle - Remote Code Execution
- Severity
- critical
- Impact
- Authenticated attackers with question creation permissions can craft malicious calculated questions to execute arbitrary commands on the underlying system.
- Remediation
- Apply security patches for Moodle addressing CVE-2024-43425.
Template by ProjectDiscovery nuclei-templates (iamnoooob, rootxharsh, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-43425 in your dependencies?
Find it across Packagist, including transitive dependencies.