CVE-2024-43398 is a medium-severity (CVSS 5.9) CWE-776 vulnerability in rexml. A fix is available for rexml — see the affected versions and patch details below.
REXML denial of service vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43398.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rexmlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The REXML gem before 3.3.6 has a DoS vulnerability when it parses an XML that has many deep elements that have same local name attributes.
If you need to parse untrusted XMLs with tree parser API like REXML::Document.new, you may be impacted to this vulnerability. If you use other parser APIs such as stream parser API and SAX2 parser API, this vulnerability is not affected.
Patches
The REXML gem 3.3.6 or later include the patch to fix the vulnerability.
Workarounds
Don't parse untrusted XMLs with tree parser API.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | rexml | all versions | 3.3.6bundle update rexml --conservative |
Affected Products
bootstrap osnetapprexmlruby-langDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rexml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rexml to 3.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43398 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate impact: Red Hat products in the current affected scope, including Red Hat Enterprise Linux and other products that ship the vulnerable REXML component, can be exposed to denial of service when an attacker supplies deeply nested XML with repeated local-name attributes to REXML's tree parser, such as…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-43398 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | ruby:3.3-8100020240906074654.489197e6 | RHSA-2024:6784 |
| Red Hat Enterprise Linux 8 | ruby:3.1-8100020250407112943.489197e6 | RHSA-2025:4063 |
| Red Hat Enterprise Linux 8 | pcs-0:0.10.18-2.el8_10.2 | RHSA-2024:6670 |
| Red Hat Enterprise Linux 8.6 Telecommunications Update Service | pcs-0:0.10.12-6.el8_6.6 | RHSA-2024:6702 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | pcs-0:0.10.15-4.el8_8.3 | RHSA-2024:6703 |
| Red Hat Enterprise Linux 9 | ruby:3.3-9040020240906110954.9 | RHSA-2024:6785 |
| Red Hat Enterprise Linux 9 | ruby:3.1-9050020250404144903.9 | RHSA-2025:4488 |
Frequently Asked Questions
Is CVE-2024-43398 in your dependencies?
Find it across RubyGems, including transitive dependencies.