CVE-2024-42490 is a high-severity (CVSS 7.5) CWE-285 vulnerability in goauthentik.io. A fix is available for goauthentik.io — see the affected versions and patch details below.
authentik has Insufficient Authorization for several API endpoints
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-42490.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
goauthentik.io🐹goauthentik.ioReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Several API endpoints can be accessed by users without correct authentication/authorization.
The main API endpoints affected by this:
/api/v3/crypto/certificatekeypairs/<uuid>/view_certificate//api/v3/crypto/certificatekeypairs/<uuid>/view_private_key//api/v3/.../used_by/
Note that all of the affected API endpoints require the knowledge of the ID of an object, which especially for certificates is not accessible to an unprivileged user. Additionally the IDs for most objects are UUIDv4, meaning they are not easily guessable/enumerable.
Patches
authentik 2024.4.4, 2024.6.4 and 2024.8.0 fix this issue.
Workarounds
Access to the API endpoints can be blocked at a Reverse-proxy/Load balancer level to prevent this issue from being exploited.
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | goauthentik.io | ≥ 2024.6.0-rc1&&< 2024.6.4 | 2024.6.4go get goauthentik.io@v2024.6.4 |
| 🐹Go | goauthentik.io | all versions | 2024.4.4go get goauthentik.io@v2024.4.4 |
Affected Products
authentikgoauthentikDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for goauthentik.io, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update goauthentik.io to 2024.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-42490 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-42490 in your dependencies?
Find it across Go, including transitive dependencies.