NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 GitHub Actions
Not in CISA KEV
MEDIUM severity

CVE-2024-42482 — syntax-check

MEDIUMFix: fish-shop/syntax-check@91e6817

CVE-2024-42482 is a medium-severity (CVSS 4.8) CWE-140 vulnerability in fish-shop/syntax-check. A fix is available for fish-shop/syntax-check — see the affected versions and patch details below.

fish-shop/syntax-check Improper Neutralization of Delimiters

Also known asGHSA-xj87-mqvh-88w2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-42482.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.32%0.66%1.01%1.35%0.8%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦fish-shop/syntax-check

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects GitHub Actions packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Improper neutralisation of delimiters in the pattern input (specifically the command separator ; and command substitution characters ( and )) mean that arbitrary command injection is possible by modification of the input value used in a workflow. This has the potential for exposure or exfiltration of sensitive information from the workflow runner, such as might be achieved by sending environment variables to an external entity.

Patches

As of this writing, the issue has been patched for versions in the v1.x.x release series in release v1.6.12 (also tagged as v1.6 and v1). The latest available release v2.0.0 also includes a corresponding patch (also tagged as v2.0 and v2).

Users should upgrade to at least the patched version v1.6.12 or preferably the latest available version v2.0.0. Workflows that use the action ref v1 will automatically receive the patched version v1.6.12 in future workflow runs.

Patch summary:

Release seriesPatched tagsPatched commit hashes
1.x.xv1.6.12, v1.6, v191e6817c48ad475542fe4e78139029b036a53b03
2.x.xv2.0.0, v2.0, v2c2cb11395e21119ff8d6e7ea050430ee7d6f49ca

Workarounds

Is it recommended that users update to the patched version v1.6.12 or the latest release version v2.0.0, however remediation may be possible through careful control of workflows and the pattern input value used by this action.

References

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦GitHub Actionsfish-shop/syntax-checkall versions1.6.12

Affected Products

1 product · 1 configurations
Application
syntax-checkfish-shop
< 1.6.12
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fish-shop/syntax-check, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fish-shop/syntax-check to 1.6.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-42482 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Impact Improper neutralisation of delimiters in the `pattern` input (specifically the command separator `;` and command substitution characters `(` and `)`) mean that arbitrary command injection is possible by modification of the input value used in a workflow. This has the potential for exposure or exfiltration of sensitive information from the workflow runner, such as might be achieved by sending environment variables to an external entity. ### Patches As of this writing, the issue has been patched for versions in the `v1.x.x` release series in release `v1.6.12` (also tagged as `v1.6`
O3 Security · Impact-Aware SCA

Is CVE-2024-42482 in your dependencies?

Find it across GitHub Actions, including transitive dependencies.

CVE-2024-42482: syntax-check — Fixed in 1.6.12