CVE-2024-42368 — bearertokenauthextension
MEDIUMFix: open-telemetry/opentelemetry-collector-contrib@c9bd3efCVE-2024-42368 is a medium-severity (CVSS 6.5) CWE-208 vulnerability in github.com/open-telemetry/opentelemetry-collector-contrib/extension/bearertokenauthextension. A fix is available for github.com/open-telemetry/opentelemetry-collector-contrib/extension/bearertokenauthextension — see the affected versions and patch details below.
open-telemetry has an Observable Timing Discrepancy
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-42368.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/open-telemetry/opentelemetry-collector-contrib/extension/bearertokenauthextensionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
The bearertokenauth extension's server authenticator performs a simple, non-constant time string comparison of the received & configured bearer tokens.
Details
For background on the type of vulnerability, see https://ropesec.com/articles/timing-attacks/.
Impact
This impacts anyone using the bearertokenauth server authenticator. Malicious clients with network access to the collector may perform a timing attack against a collector with this authenticator to guess the configured token, by iteratively sending tokens and comparing the response time. This would allow an attacker to introduce fabricated or bad data into the collector's telemetry pipeline.
Fix
The observable timing vulnerability was fixed by @axw in v0.107.0 (PR https://github.com/open-telemetry/opentelemetry-collector-contrib/pull/34516) by using constant-time comparison.
Workarounds
- upgrade to v0.107.0 or above, or, if you're unable to upgrade at this time,
- don't expose the receiver using
bearertokenauthto network segments accessible by potential attackers, or - change the receiver to use a different authentication extension instead, or
- disable the receiver relying on
bearertokenauth
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/open-telemetry/opentelemetry-collector-contrib/extension/bearertokenauthextension | ≥ 0.80.0&&< 0.107.0 | 0.107.0go get github.com/open-telemetry/opentelemetry-collector-contrib/extension/bearertokenauthextension@v0.107.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/open-telemetry/opentelemetry-collector-contrib/extension/bearertokenauthextension, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/open-telemetry/opentelemetry-collector-contrib/extension/bearertokenauthextension to 0.107.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-42368 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-42368 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Openshift distributed tracing 3.3 | rhosdt/jaeger-agent-rhel8:1.57.0-10 | RHSA-2024:6274 |
Frequently Asked Questions
Is CVE-2024-42368 in your dependencies?
Find it across Go, including transitive dependencies.