CVE-2024-41989 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django memory consumption vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-41989.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. The floatformat template filter is subject to significant memory consumption when given a string representation of a number in scientific notation with a large exponent.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 5.0&&< 5.0.8 | 5.0.8pip install --upgrade 'django==5.0.8' |
| 🐍PyPI | django | ≥ 4.2&&< 4.2.15 | 4.2.15pip install --upgrade 'django==4.2.15' |
Affected Products
djangodjangoprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 5.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-41989 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue is categorized as moderate severity rather than important because, while it has the potential to cause significant memory consumption under specific conditions, the likelihood of such a scenario occurring in typical applications is relatively low. The issue arises primarily when processing extremely large…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-41989 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.12.0-1 | RHSA-2025:1249 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | python3x-django-0:4.2.15-1.el8ap | RHSA-2024:6428 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | automation-controller-0:4.6.2-1.el8ap | RHSA-2024:8534 |
| RHUI 4 for RHEL 8 | python-django-0:4.2.15-1.el8ui | RHSA-2025:1335 |
Frequently Asked Questions
Is CVE-2024-41989 in your dependencies?
Find it across PyPI, including transitive dependencies.