NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2024-4183 — mattermost-server

MEDIUMFix: mattermost/mattermost@86920d6

CVE-2024-4183 is a medium-severity (CVSS 4.3) Uncontrolled Resource Consumption vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Mattermost fails to limit the number of active sessions

Also known asGHSA-wj37-mpq9-xrcmGO-2024-2798
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-4183.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.74%1.11%0.2%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessions, which allows an authenticated attacker to crash the server via repeated requests to the getSessions API after flooding the sessions table.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server≥ 9.6.0-rc1&&< 9.6.19.6.1go get github.com/mattermost/mattermost-server@v9.6.1
🐹Gogithub.com/mattermost/mattermost-server≥ 9.5.0&&< 9.5.39.5.3go get github.com/mattermost/mattermost-server@v9.5.3
🐹Gogithub.com/mattermost/mattermost-server≥ 9.4.0&&< 9.4.59.4.5go get github.com/mattermost/mattermost-server@v9.4.5
🐹Gogithub.com/mattermost/mattermost-server≥ 8.1.0&&< 8.1.128.1.12go get github.com/mattermost/mattermost-server@v8.1.12

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 9.6.0 && < 9.6.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 9.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-4183 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessions, which allows an authenticated attacker to crash the server via repeated requests to the getSessions API after flooding the sessions table.
O3 Security · Impact-Aware SCA

Is CVE-2024-4183 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-4183: mattermost-server — Fixed in 9.6.1