NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2024-41122 — woodpecker

HIGHFix: woodpecker-ci/woodpecker#3909

CVE-2024-41122 is a high-severity (CVSS 7.5) CWE-74 vulnerability in go.woodpecker-ci.org/woodpecker/v2. A fix is available for go.woodpecker-ci.org/woodpecker/v2 — see the affected versions and patch details below.

Custom environment variables allow to alter execution flow of plugins in Woodpecker

Also known asGHSA-3wf2-2pq4-4rvcGO-2024-2998
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-41122.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.75%1.12%0.3%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹go.woodpecker-ci.org/woodpecker/v2🐹go.woodpecker-ci.org/woodpecker

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The server allow to create any user who can trigger a pipeline run malicious workflows:

  • Those workflows can either lead to a host takeover that runs the agent executing the workflow.
  • Or allow to extract the secrets who would be normally provided to the plugins who's entrypoint are overwritten.

Patches

https://github.com/woodpecker-ci/woodpecker/pull/3909 https://github.com/woodpecker-ci/woodpecker/pull/3934

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading? Enable the "gated" repo feature and review each change upfront of running

References

Credits

  • Daniel Kilimnik @D_K_Dev (Neodyme AG)
  • Felipe Custodio Romero @localo (Neodyme AG)

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogo.woodpecker-ci.org/woodpecker/v2all versions2.7.0go get go.woodpecker-ci.org/woodpecker/v2@v2.7.0
🐹Gogo.woodpecker-ci.org/woodpeckerall versions2.7.0go get go.woodpecker-ci.org/woodpecker@v2.7.0

Affected Products

1 product · 1 configurations
Application
woodpeckerwoodpecker-ci
< 2.7.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for go.woodpecker-ci.org/woodpecker/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update go.woodpecker-ci.org/woodpecker/v2 to 2.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-41122 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact The server allow to create any user who can trigger a pipeline run malicious workflows: - Those workflows can either lead to a host takeover that runs the agent executing the workflow. - Or allow to extract the secrets who would be normally provided to the plugins who's entrypoint are overwritten. ### Patches https://github.com/woodpecker-ci/woodpecker/pull/3909 https://github.com/woodpecker-ci/woodpecker/pull/3934 ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ **Enable the "gated" repo feature and review each change upfront of
O3 Security · Impact-Aware SCA

Is CVE-2024-41122 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-41122: woodpecker — Fixed in 2.7.0