NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2024-40453 — squirrelly

CRITICALFix: squirrellyjs/squirrelly#262

CVE-2024-40453 is a critical-severity (CVSS 9.8) Code Injection vulnerability in squirrelly. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for squirrelly — see the affected versions and patch details below.

squirrelly Code Injection vulnerability

Also known asGHSA-w5pw-gmcw-rfc8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-40453.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.42%1.68%2.93%4.19%3.5%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

68other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
squirrellynpm
81Kdownloads / week

Description

squirrellyjs squirrelly v9.0.0 was discovered to contain a code injection vulnerability via the component options.varName. The issue was fixed in version 9.1.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsquirrelly≥ 9.0.0&&< 9.1.09.1.0npm install squirrelly@9.1.0

Affected Products

1 product · 1 configurations
Application
squirrellysquirrelly
1 version
9.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for squirrelly, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update squirrelly to 9.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-40453 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

squirrellyjs squirrelly v9.0.0 was discovered to contain a code injection vulnerability via the component `options.varName`. The issue was fixed in version 9.1.0.
O3 Security · Impact-Aware SCA

Is CVE-2024-40453 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-40453: squirrelly RCE — Fixed in 9.1.0