CVE-2024-40094 is a medium-severity (CVSS 5.3) vulnerability in com.graphql-java:graphql-java. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for com.graphql-java:graphql-java — see the affected versions and patch details below.
GraphQL Java does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of service
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-40094.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.graphql-java:graphql-java☕com.graphql-java:graphql-java☕com.graphql-java:graphql-javaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
GraphQL Java (aka graphql-java) before 21.5 does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of service via introspection queries. 20.9 and 19.11 are also fixed versions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.graphql-java:graphql-java | all versions | 19.11com.graphql-java:graphql-java:19.11 |
| ☕Maven | com.graphql-java:graphql-java | ≥ 20.0&&< 20.9 | 20.9com.graphql-java:graphql-java:20.9 |
| ☕Maven | com.graphql-java:graphql-java | ≥ 21.0&&< 21.5 | 21.5com.graphql-java:graphql-java:21.5 |
Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.graphql-java:graphql-java, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.graphql-java:graphql-java to 19.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-40094 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate: This flaw in GraphQL Java allows for a denial of service by enabling attackers to craft specific introspection queries that lead to excessive resource allocation. This can result in resource exhaustion and service unavailability in Red Hat products utilizing the affected library.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2024-40094 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Cryostat 3 on RHEL 8 | cryostat-tech-preview/cryostat-db-rhel8:3.0.1-5 | RHSA-2024:8329 |
| Red Hat build of Quarkus Native builder | com.graphql-java.graphql-java | RHSA-2024:7676 |
| Red Hat build of Quarkus Native builder | com.graphql-java.graphql-java | RHSA-2024:7670 |
| RHOSS-1.35-RHEL-8 | openshift-serverless-1/logic-data-index-ephemeral-rhel8:1.35.0-5 | RHSA-2025:0664 |
Frequently Asked Questions
Is CVE-2024-40094 in your dependencies?
Find it across Maven, including transitive dependencies.