NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2024-39887 — apache-superset

MEDIUMFix: apache/superset@56f0103

CVE-2024-39887 is a medium-severity (CVSS 4.3) SQL Injection vulnerability in apache-superset. A fix is available for apache-superset — see the affected versions and patch details below.

Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions

Also known asBIT-superset-2024-39887GHSA-2q6j-vpvr-6pvjPYSEC-2026-1155
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-39887.

EPSS Exploitation Probability

via FIRST.org ↗
4.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%27.2%54.4%81.7%63.8%4.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍apache-superset

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection.

This issue affects Apache Superset: before 4.0.2.

Users are recommended to upgrade to version 4.0.2, which fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIapache-supersetall versions4.0.2pip install --upgrade 'apache-superset==4.0.2'

Affected Products

1 product · 1 configurations
Application
supersetapache
< 4.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-superset, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apache-superset to 4.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-39887 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

How to detect CVE-2024-39887

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-39887 -u https://target
Template
Apache Superset < 4.0.2 - SQL Injection
Severity
medium
Impact
Authenticated attackers can bypass SQL authorization to execute restricted database queries.
Remediation
Users are recommended to upgrade to version 4.0.2, which fixes the issue.

Template by ProjectDiscovery nuclei-templates (iamnoooob, rootxharsh, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection. This issue affects Apache Superset: be
O3 Security · Impact-Aware SCA

Is CVE-2024-39887 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-39887: apache SQL Injection — Fixed in 4.0.2