NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-39404 — project-community-edition

MEDIUM

CVE-2024-39404 is a medium-severity (CVSS 4.3) CWE-285 vulnerability in magento/project-community-edition. A fix is available for magento/project-community-edition — see the affected versions and patch details below.

A user without Shop Policy Parameters section privilege can alter the shop policy parameters section

Also known asGHSA-qrh3-vxjg-h9h6
Published
Updated
Affected
9 pkgs
Patched
4 / 9
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-39404.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.32%0.64%0.95%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐘magento/project-community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass security measures and modify minor information. Exploitation of this issue does not require user interaction.

Affected Packages

9 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/project-community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p22.4.7-p2composer require magento/community-edition:^2.4.7-p2
🐘Packagistmagento/community-edition≥ 2.4.6-p1&&< 2.4.6-p72.4.6-p7composer require magento/community-edition:^2.4.6-p7
🐘Packagistmagento/community-edition≥ 2.4.5-p1&&< 2.4.5-p92.4.5-p9composer require magento/community-edition:^2.4.5-p9
🐘Packagistmagento/community-edition≥ 2.4.4-p1&&< 2.4.4-p102.4.4-p10composer require magento/community-edition:^2.4.4-p10
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

2 products · 62 configurations
Application
commerceadobe
≤ 2.4.3
4 versions
2.4.42.4.52.4.62.4.7
Application
magentoadobe
≤ 2.4.3
4 versions
2.4.42.4.52.4.62.4.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/project-community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2024-39404; check the affected-versions list above or the advisory for the patched release of magento/project-community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass security measures and modify minor information. Exploitation of this issue does not require user interaction.
O3 Security · Impact-Aware SCA

Is CVE-2024-39404 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-39404: project-community — Fixed in 2.4.7-p2