NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2024-39402 — project-community-edition

HIGH

CVE-2024-39402 is a high-severity (CVSS 8.4) OS Command Injection vulnerability in magento/project-community-edition. A fix is available for magento/project-community-edition — see the affected versions and patch details below.

Adobe Commerce | Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') (CWE-78)

Also known asGHSA-2ff6-837j-hg5x
Published
Updated
Affected
9 pkgs
Patched
4 / 9
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-39402.

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
1.03%1.73%2.44%3.14%2.6%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐘magento/project-community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an admin attacker. Exploitation of this issue requires user interaction and scope is changed.

Affected Packages

9 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/project-community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p22.4.7-p2composer require magento/community-edition:^2.4.7-p2
🐘Packagistmagento/community-edition≥ 2.4.6-p1&&< 2.4.6-p72.4.6-p7composer require magento/community-edition:^2.4.6-p7
🐘Packagistmagento/community-edition≥ 2.4.5-p1&&< 2.4.5-p92.4.5-p9composer require magento/community-edition:^2.4.5-p9
🐘Packagistmagento/community-edition≥ 2.4.4-p1&&< 2.4.4-p102.4.4-p10composer require magento/community-edition:^2.4.4-p10
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

2 products · 62 configurations
Application
commerceadobe
≤ 2.4.3
4 versions
2.4.42.4.52.4.62.4.7
Application
magentoadobe
≤ 2.4.3
4 versions
2.4.42.4.52.4.62.4.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/project-community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2024-39402; check the affected-versions list above or the advisory for the patched release of magento/project-community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an admin attacker. Exploitation of this issue requires user interaction and scope is changed.
O3 Security · Impact-Aware SCA

Is CVE-2024-39402 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-39402: project-community — Fixed in 2.4.7-p2