NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2024-39400 — project-community-edition

HIGH

CVE-2024-39400 is a high-severity (CVSS 8.1) Cross-site Scripting (XSS) vulnerability in magento/project-community-edition. A fix is available for magento/project-community-edition — see the affected versions and patch details below.

DOM XSS through integrations can impact other admins

Also known asGHSA-52fg-wjxm-pp44
Published
Updated
Affected
9 pkgs
Patched
4 / 9
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-39400.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.14%0.75%1.36%1.97%1.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐘magento/project-community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by a DOM-based Cross-Site Scripting (XSS) vulnerability. This vulnerability could allow an admin attacker to inject and execute arbitrary JavaScript code within the context of the user's browser session. Exploitation of this issue requires user interaction, such as convincing a victim to click on a malicious link. Confidentiality and integrity impact is high as it affects other admin accounts.

Affected Packages

9 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/project-community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p22.4.7-p2composer require magento/community-edition:^2.4.7-p2
🐘Packagistmagento/community-edition≥ 2.4.6-p1&&< 2.4.6-p72.4.6-p7composer require magento/community-edition:^2.4.6-p7
🐘Packagistmagento/community-edition≥ 2.4.5-p1&&< 2.4.5-p92.4.5-p9composer require magento/community-edition:^2.4.5-p9
🐘Packagistmagento/community-edition≥ 2.4.4-p1&&< 2.4.4-p102.4.4-p10composer require magento/community-edition:^2.4.4-p10
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

2 products · 62 configurations
Application
commerceadobe
≤ 2.4.3
4 versions
2.4.42.4.52.4.62.4.7
Application
magentoadobe
≤ 2.4.3
4 versions
2.4.42.4.52.4.62.4.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/project-community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2024-39400; check the affected-versions list above or the advisory for the patched release of magento/project-community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by a DOM-based Cross-Site Scripting (XSS) vulnerability. This vulnerability could allow an admin attacker to inject and execute arbitrary JavaScript code within the context of the user's browser session. Exploitation of this issue requires user interaction, such as convincing a victim to click on a malicious link. Confidentiality and integrity impact is high as it affects other admin accounts.
O3 Security · Impact-Aware SCA

Is CVE-2024-39400 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-39400: project-community — Fixed in 2.4.7-p2