NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-39322 — ai-admin-jsonadm

MEDIUMFix: aimeos/ai-admin-jsonadm@02a063f

CVE-2024-39322 is a medium-severity (CVSS 5.5) CWE-863 vulnerability in aimeos/ai-admin-jsonadm. A fix is available for aimeos/ai-admin-jsonadm — see the affected versions and patch details below.

aimeos/ai-admin-jsonadm improper access control vulnerability allows editors to remove required records

Also known asGHSA-8fj2-587w-5whr
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-39322.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.65%0.98%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘aimeos/ai-admin-jsonadm🐘aimeos/ai-admin-jsonadm🐘aimeos/ai-admin-jsonadm🐘aimeos/ai-admin-jsonadm🐘aimeos/ai-admin-jsonadm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

aimeos/ai-admin-jsonadm is the Aimeos e-commerce JSON API for administrative tasks. In versions prior to 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2, improper access control allows editors to remove admin group and locale configuration in the Aimeos backend. Versions 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2 contain a fix for the issue.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistaimeos/ai-admin-jsonadm≥ 2024.04.1&&< 2024.04.22024.04.2composer require aimeos/ai-admin-jsonadm:^2024.04.2
🐘Packagistaimeos/ai-admin-jsonadm≥ 2023.04.1&&< 2023.10.42023.10.4composer require aimeos/ai-admin-jsonadm:^2023.10.4
🐘Packagistaimeos/ai-admin-jsonadm≥ 2022.04.1&&< 2022.10.32022.10.3composer require aimeos/ai-admin-jsonadm:^2022.10.3
🐘Packagistaimeos/ai-admin-jsonadm≥ 2021.04.1&&< 2021.10.62021.10.6composer require aimeos/ai-admin-jsonadm:^2021.10.6
🐘Packagistaimeos/ai-admin-jsonadmall versions2020.10.13composer require aimeos/ai-admin-jsonadm:^2020.10.13

Affected Products

1 product · 5 configurations
Application
ai-controller-frontendaimeos_project
≥ 2023.04.1 && < 2023.10.4
1 version
2024.04.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aimeos/ai-admin-jsonadm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aimeos/ai-admin-jsonadm to 2024.04.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-39322 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

aimeos/ai-admin-jsonadm is the Aimeos e-commerce JSON API for administrative tasks. In versions prior to 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2, improper access control allows editors to remove admin group and locale configuration in the Aimeos backend. Versions 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2 contain a fix for the issue.
O3 Security · Impact-Aware SCA

Is CVE-2024-39322 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-39322: ai-admin-jsonadm — Fixed in 2024.04.2