CVE-2024-3848 is a high-severity (CVSS 7.5) CWE-29 vulnerability in mlflow. EPSS puts its 30-day exploitation probability at 43.3% (99th percentile). A fix is available for mlflow — see the affected versions and patch details below.
Path Traversal Bypass in mlflow/mlflow
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-3848.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mlflowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A path traversal vulnerability exists in mlflow/mlflow version 2.11.0, identified as a bypass for the previously addressed CVE-2023-6909. The vulnerability arises from the application's handling of artifact URLs, where a '#' character can be used to insert a path into the fragment, effectively skipping validation. This allows an attacker to construct a URL that, when processed, ignores the protocol scheme and uses the provided path for filesystem access. As a result, an attacker can read arbitrary files, including sensitive information such as SSH and cloud keys, by exploiting the way the application converts the URL into a filesystem path. The issue stems from insufficient validation of the fragment portion of the URL, leading to arbitrary file read through path traversal.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | mlflow | ≥ 2.9.2&&< 2.12.1 | 2.12.1pip install --upgrade 'mlflow==2.12.1' |
Affected Products
mlflowlfprojectsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mlflow to 2.12.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-3848 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
How to detect CVE-2024-3848
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-3848 -u https://target- Template
- Mlflow < 2.11.0 - Path Traversal
- Severity
- high
- Impact
- Successful exploitation could be lead to disclose of sensitive information such as SSH Keys or Internal configurations.
- Remediation
- To fix this vulnerability, it is important to update the mlflow package to the latest version 2.12.1.
Template by ProjectDiscovery nuclei-templates (gy741), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat has classified this vulnerability as Important because an unauthenticated network adversary can retrieve arbitrary files from the underlying container or host, threatening the confidentiality of sensitive credentials. Within Red Hat OpenShift AI environments, MLflow services and workbench runtimes that process…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability. --- CME Mitigation Guidance (2026-11-04) --- Disclaimer: The following mitigation solutions are provided as a courtesy, pending the application of an official patch. This content was generated utilizing AI tools in conjunction with data from https://cmetaxonomy.org. Customers are advised to independently evaluate and test these temporary mitigations within their own infrastructure. The highest-value action is to reject artifact_location parameter inputs…Source: Red Hat security advisory for CVE-2024-3848 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-3848 in your dependencies?
Find it across PyPI, including transitive dependencies.