NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-38277 — moodle

MEDIUMFix: moodle/moodle@0caedaa

CVE-2024-38277 is a medium-severity (CVSS 5.4) CWE-324 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

moodle: QR login key and auto-login key for the Moodle mobile app should be generated as separate keys

Also known asBIT-moodle-2024-38277GHSA-r82w-3phg-qvr4
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38277.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs16th percentile — riskier than 16% of all scored CVEsHighest risk
0.00%0.25%0.50%0.75%0.2%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A unique key should be generated for a user's QR login key and their auto-login key, so the same key cannot be used interchangeably between the two.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.4.0-beta&&< 4.4.14.4.1composer require moodle/moodle:^4.4.1
🐘Packagistmoodle/moodle≥ 4.3.0-beta&&< 4.3.54.3.5composer require moodle/moodle:^4.3.5
🐘Packagistmoodle/moodle≥ 4.2.0-beta&&< 4.2.84.2.8composer require moodle/moodle:^4.2.8
🐘Packagistmoodle/moodleall versions4.1.11composer require moodle/moodle:^4.1.11

Affected Products

2 products · 6 configurations
OS
fedorafedoraproject
2 versions
3940
Application
moodlemoodle
≥ 4.3.0 && < 4.3.5
1 version
4.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38277 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A unique key should be generated for a user's QR login key and their auto-login key, so the same key cannot be used interchangeably between the two.
O3 Security · Impact-Aware SCA

Is CVE-2024-38277 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-38277: moodle — Fixed in 4.4.1