CVE-2024-38276 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
moodle: CSRF risks due to misuse of confirm_sesskey
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38276.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect CSRF token checks resulted in multiple CSRF risks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.1 | 4.4.1composer require moodle/moodle:^4.4.1 |
| 🐘Packagist | moodle/moodle | ≥ 4.3.0-beta&&< 4.3.5 | 4.3.5composer require moodle/moodle:^4.3.5 |
| 🐘Packagist | moodle/moodle | ≥ 4.2.0-beta&&< 4.2.8 | 4.2.8composer require moodle/moodle:^4.2.8 |
| 🐘Packagist | moodle/moodle | all versions | 4.1.11composer require moodle/moodle:^4.1.11 |
Affected Products
fedorafedoraprojectmoodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38276 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-38276 in your dependencies?
Find it across Packagist, including transitive dependencies.