CVE-2024-38273 is a medium-severity (CVSS 5.4) CWE-284 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
moodle: BigBlueButton web service leaks meeting joining information to users who should not have access
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38273.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Insufficient capability checks meant it was possible for users to gain access to BigBlueButton join URLs they did not have permission to access.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.1 | 4.4.1composer require moodle/moodle:^4.4.1 |
| 🐘Packagist | moodle/moodle | ≥ 4.3.0-beta&&< 4.3.5 | 4.3.5composer require moodle/moodle:^4.3.5 |
| 🐘Packagist | moodle/moodle | ≥ 4.2.0-beta&&< 4.2.8 | 4.2.8composer require moodle/moodle:^4.2.8 |
| 🐘Packagist | moodle/moodle | all versions | 4.1.11composer require moodle/moodle:^4.1.11 |
Affected Products
fedorafedoraprojectmoodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38273 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-38273 in your dependencies?
Find it across Packagist, including transitive dependencies.