NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-36827 — ebookmeta

HIGH

CVE-2024-36827 is a high-severity (CVSS 7.5) XML External Entity (XXE) vulnerability in ebookmeta. A fix is available for ebookmeta — see the affected versions and patch details below.

ebookmeta XML External Entity vulnerability

Also known asGHSA-whf4-fpj8-pgg8PYSEC-2024-76
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-36827.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.33%0.67%1.00%0.1%0.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ebookmeta

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An XML External Entity (XXE) vulnerability in the ebookmeta.get_metadata function of ebookmeta before v1.2.8 allows attackers to access sensitive information or cause a Denial of Service (DoS) via crafted XML input.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIebookmetaall versions1.2.8pip install --upgrade 'ebookmeta==1.2.8'

Affected Products

1 product · 1 configurations
Application
ebookmetadnkorpushov
< 1.2.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ebookmeta, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ebookmeta to 1.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-36827 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

An XML External Entity (XXE) vulnerability in the ebookmeta.get_metadata function of ebookmeta before v1.2.8 allows attackers to access sensitive information or cause a Denial of Service (DoS) via crafted XML input.
O3 Security · Impact-Aware SCA

Is CVE-2024-36827 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-36827: ebookmeta DoS — Fixed in 1.2.8