CVE-2024-36124 — snappy
MEDIUMCVE-2024-36124 is a medium-severity (CVSS 5.3) Out-of-bounds Read vulnerability in org.iq80.snappy:snappy. A fix is available for org.iq80.snappy:snappy — see the affected versions and patch details below.
iq80 Snappy has an out-of-bounds read when uncompressing data, leading to JVM crash
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-36124.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.iq80.snappy:snappyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
iq80 Snappy performs out-of-bounds read access when uncompressing certain data, which can lead to a JVM crash.
Details
When uncompressing certain data, Snappy tries to read outside the bounds of the given byte arrays. Because Snappy uses the JDK class sun.misc.Unsafe to speed up memory access, no additional bounds checks are performed and this has similar security consequences as out-of-bounds access in C or C++, namely it can lead to non-deterministic behavior or crash the JVM.
iq80 Snappy is not actively maintained anymore. As quick fix users can upgrade to version 0.5, but in the long term users should prefer migrating to the Snappy implementation in https://github.com/airlift/aircompressor (version 0.27 or newer).
Impact
When uncompressing data from untrusted users, this can be exploited for a denial-of-service attack by crashing the JVM.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.iq80.snappy:snappy | all versions | 0.5org.iq80.snappy:snappy:0.5 |
Affected Products
snappydainDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.iq80.snappy:snappy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.iq80.snappy:snappy to 0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-36124 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate impact: CVE-2024-36124 affects Red Hat products that include the iq80 Snappy compression/decompression component, including affected Red Hat Integration, Red Hat build of Apache Camel, Red Hat Ansible Automation Platform and Ansible Services, OpenShift Container Platform, JBoss Data Grid, Red Hat JBoss Fuse,…
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-36124 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-36124 in your dependencies?
Find it across Maven, including transitive dependencies.