CVE-2024-35239 — Umbraco.Forms
LOWCVE-2024-35239 is a low-severity (CVSS 2.7) Cross-site Scripting (XSS) vulnerability in Umbraco.Forms. A fix is available for Umbraco.Forms — see the affected versions and patch details below.
Umbraco Forms components vulnerable to Stored Cross-site Scripting
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-35239.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Umbraco.Forms.NETUmbraco.Forms.NETUmbraco.Forms.NETUmbraco.FormsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Authenticated user that has access to edit Forms may inject unsafe code into Forms components.
Patches
Issue can be mitigated by configuring TitleAndDescription:AllowUnsafeHtmlRendering after upgrading to patched versions (13.0.1, 12.2.2, 10.5.3, 8.13.13).
References
https://docs.umbraco.com/umbraco-forms/release-notes#id-13.0.1-january-16th-2024 https://docs.umbraco.com/umbraco-forms/v/12.forms.latest/release-notes#id-12.2.2-january-16th-2024 https://docs.umbraco.com/umbraco-forms/v/10.forms.latest/release-notes https://docs.umbraco.com/umbraco-forms/developer/configuration#editing-configuration-values
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Umbraco.Forms | ≥ 13.0.0&&< 13.0.1 | 13.0.1dotnet add package Umbraco.Forms --version 13.0.1 |
| .NETNuGet | Umbraco.Forms | ≥ 12.0.0&&< 12.2.2 | 12.2.2dotnet add package Umbraco.Forms --version 12.2.2 |
| .NETNuGet | Umbraco.Forms | ≥ 10.0.0&&< 10.5.3 | 10.5.3dotnet add package Umbraco.Forms --version 10.5.3 |
| .NETNuGet | Umbraco.Forms | ≥ 8.0.0&&< 8.13.13 | 8.13.13dotnet add package Umbraco.Forms --version 8.13.13 |
Affected Products
umbraco formsumbracoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Umbraco.Forms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Umbraco.Forms to 13.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-35239 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-35239 in your dependencies?
Find it across NuGet, including transitive dependencies.