CVE-2024-34707 is a high-severity (CVSS 7.5) Cross-site Scripting (XSS) vulnerability in nautobot. A fix is available for nautobot — see the affected versions and patch details below.
Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-34707.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nautobot🐍nautobotReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A Nautobot user with admin privileges can modify the BANNER_TOP, BANNER_BOTTOM, and BANNER_LOGIN configuration settings via the /admin/constance/config/ endpoint. Normally these settings are used to provide custom banner text at the top and bottom of all Nautobot web pages (or specifically on the login page in the case of BANNER_LOGIN) but it was reported that an admin user can make use of these settings to inject arbitrary HTML, potentially exposing Nautobot users to security issues such as cross-site scripting (stored XSS).
Patches
Has the problem been patched? What versions should users upgrade to?
Patches will be released as part of Nautobot 1.6.22 and 2.2.4.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
As described in the Nautobot documentation, these settings are only configurable through the admin UI of Nautobot if they are not explicitly set to some non-empty value in the nautobot_config.py or equivalent Nautobot configuration file. Therefore, adding the following configuration to said file completely mitigates this vulnerability in both Nautobot 1.x and 2.x:
BANNER_LOGIN = " "
BANNER_TOP = " "
BANNER_BOTTOM = " "
or alternately (Nautobot 2.x only), if those variables are not defined explicitly in your configuration file, setting the following environment variables for the Nautobot user account serves the same purpose:
NAUTOBOT_BANNER_LOGIN=" "
NAUTOBOT_BANNER_TOP=" "
NAUTOBOT_BANNER_BOTTOM=" "
Limiting all users who do not need elevated privileges to non-admin access (is_superuser: False and is_staff: False) is a partial mitigation as well.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nautobot | all versions | 1.6.22pip install --upgrade 'nautobot==1.6.22' |
| 🐍PyPI | nautobot | ≥ 2.0.0&&< 2.2.4 | 2.2.4pip install --upgrade 'nautobot==2.2.4' |
Affected Products
nautobotnetworktocodeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nautobot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nautobot to 1.6.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-34707 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-34707 in your dependencies?
Find it across PyPI, including transitive dependencies.