CVE-2024-32036 is a medium-severity (CVSS 5.3) CWE-226 vulnerability in SixLabors.ImageSharp. A fix is available for SixLabors.ImageSharp — see the affected versions and patch details below.
SixLabors.ImageSharp vulnerable to data leakage
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-32036.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
SixLabors.ImageSharp.NETSixLabors.ImageSharpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A data leakage flaw was found in ImageSharp's JPEG and TGA decoders. This vulnerability is triggered when an attacker passes a specially crafted JPEG or TGA image file to a software using ImageSharp, potentially disclosing sensitive information from other parts of the software in the resulting image buffer.
Patches
The problem has been patched. All users are advised to upgrade to v3.1.4 or v2.1.8.
Workarounds
None
References
None
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | SixLabors.ImageSharp | all versions | 2.1.8dotnet add package SixLabors.ImageSharp --version 2.1.8 |
| .NETNuGet | SixLabors.ImageSharp | ≥ 3.0.0&&< 3.1.4 | 3.1.4dotnet add package SixLabors.ImageSharp --version 3.1.4 |
Affected Products
imagesharpsixlaborsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for SixLabors.ImageSharp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update SixLabors.ImageSharp to 2.1.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-32036 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2024-32036 in your dependencies?
Find it across NuGet, including transitive dependencies.