CVE-2024-31997 is a critical-severity (CVSS 9.9) CWE-862 vulnerability in org.xwiki.platform:xwiki-platform-uiextension-api. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-uiextension-api — see the affected versions and patch details below.
XWiki Platform remote code execution from account through UIExtension parameters
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-31997.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-uiextension-api☕org.xwiki.platform:xwiki-platform-uiextension-api☕org.xwiki.platform:xwiki-platform-uiextension-apiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Parameters of UI extensions are always interpreted as Velocity code and executed with programming rights. Any user with edit right on any document like the user's own profile can create UI extensions. This allows remote code execution and thereby impacts the confidentiality, integrity and availability of the whole XWiki installation.
To reproduce, edit your user profile with the object editor and add a UIExtension object with the following values:
Extension Point ID: org.xwiki.platform.panels.Applications
Extension ID: platform.panels.myFakeApplication
Extension parameters:
label=I got programming right: $services.security.authorization.hasAccess('programming')
target=Main.WebHome
targetQueryString=
icon=icon:bomb
Extension Scope: "Current User".
Save the document and open any document. If an application entry with the text "I got programming right: true" is displayed, the attack succeeded, if the code in "label" is displayed literally, the XWiki installation isn't vulnerable.
Patches
This vulnerability has been patched in XWiki 14.10.19, 15.5.4 and 15.9-RC1.
Workarounds
We're not aware of any workarounds apart from upgrading.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-uiextension-api | all versions | 14.10.19org.xwiki.platform:xwiki-platform-uiextension-api:14.10.19 |
| ☕Maven | org.xwiki.platform:xwiki-platform-uiextension-api | ≥ 15.0-rc-1&&< 15.5.4 | 15.5.4org.xwiki.platform:xwiki-platform-uiextension-api:15.5.4 |
| ☕Maven | org.xwiki.platform:xwiki-platform-uiextension-api | ≥ 15.6-rc-1&&< 15.9-rc-1 | 15.9-rc-1org.xwiki.platform:xwiki-platform-uiextension-api:15.9-rc-1 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-uiextension-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-uiextension-api to 14.10.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-31997 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-31997 in your dependencies?
Find it across Maven, including transitive dependencies.