CVE-2024-29892 — zitadel
MEDIUMCVE-2024-29892 is a medium-severity (CVSS 6.1) CWE-863 vulnerability in github.com/zitadel/zitadel. A fix is available for github.com/zitadel/zitadel — see the affected versions and patch details below.
ZITADEL's actions can overload reserved claims
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29892.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadelReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Under certain circumstances an action could set reserved claims managed by ZITADEL.
For example it would be possible to set the claim urn:zitadel:iam:user:resourceowner:name
{"urn:zitadel:iam:user:resourceowner:name": "ACME"}
if it was not set by ZITADEL itself.
To compensate for this we introduced a protection that does prevent actions from changing claims that start with urn:zitadel:iam
Patches
2.x versions are fixed on >= 2.48.3 2.47.x versions are fixed on >= 2.47.8 2.46.x versions are fixed on >= 2.46.5 2.45.x versions are fixed on >= 2.45.5 2.44.x versions are fixed on >= 2.44.7 2.43.x versions are fixed on >= 2.43.11 2.42.x versions are fixed on >= 2.42.17
Workarounds
No workaround available since a patch is available
Credits
Many thanks to @schettn whose disclosure of another topic lead us to find this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/zitadel/zitadel | all versions | 2.42.17go get github.com/zitadel/zitadel@v2.42.17 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.43.0&&< 2.43.11 | 2.43.11go get github.com/zitadel/zitadel@v2.43.11 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.44.0&&< 2.44.7 | 2.44.7go get github.com/zitadel/zitadel@v2.44.7 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.45.0&&< 2.45.5 | 2.45.5go get github.com/zitadel/zitadel@v2.45.5 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.46.0&&< 2.46.5 | 2.46.5go get github.com/zitadel/zitadel@v2.46.5 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.47.0&&< 2.47.8 | 2.47.8go get github.com/zitadel/zitadel@v2.47.8 |
Affected Products
zitadelzitadelDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/zitadel/zitadel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/zitadel/zitadel to 2.42.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29892 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-29892 in your dependencies?
Find it across Go, including transitive dependencies.