NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2024-29272 — vvvebJs

MEDIUMFix: givanz/VvvebJs@c6422cf

CVE-2024-29272 is a medium-severity (CVSS 6.5) Unrestricted File Upload vulnerability in vvvebJs. A fix is available for vvvebJs — see the affected versions and patch details below.

VvvebJs Arbitrary File Upload vulnerability

Also known asGHSA-pmm3-68q9-57jg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29272.

EPSS Exploitation Probability

via FIRST.org ↗
9.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%89.4%9.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦vvvebJs

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects npm packages — download data is not available via public APIs for these ecosystems.

Description

Arbitrary File Upload vulnerability in VvvebJs before version 1.7.5, allows unauthenticated remote attackers to execute arbitrary code and obtain sensitive information via the sanitizeFileName parameter in save.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmvvvebJsall versions1.7.5npm install vvvebJs@1.7.5

Affected Products

1 product · 1 configurations
Application
vvvebjsvvveb
< 1.7.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vvvebJs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update vvvebJs to 1.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29272 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

How to detect CVE-2024-29272

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-29272 -u https://target
Template
VvvebJs < 1.7.5 - Arbitrary File Upload
Severity
medium
Impact
Attackers can upload malicious files to the server, potentially leading to remote code execution.
Remediation
Update VvvebJs to version 1.7.5 or later.

Template by ProjectDiscovery nuclei-templates (s4e-io), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Arbitrary File Upload vulnerability in VvvebJs before version 1.7.5, allows unauthenticated remote attackers to execute arbitrary code and obtain sensitive information via the sanitizeFileName parameter in save.php.
O3 Security · Impact-Aware SCA

Is CVE-2024-29272 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-29272: vvvebJs RCE — Fixed in 1.7.5