NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2024-29221 — server

MEDIUMFix: mattermost/mattermost@0dc03fb

CVE-2024-29221 is a medium-severity (CVSS 4.7) CWE-284 vulnerability in github.com/mattermost/mattermost/server/v8. A fix is available for github.com/mattermost/mattermost/server/v8 — see the affected versions and patch details below.

Invite ID available to team admins even without the "Add Members" permission

Also known asBIT-mattermost-2024-29221GHSA-w67v-ph4x-f48qGO-2024-2706
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29221.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs26th percentile — riskier than 26% of all scored CVEsHighest risk
0.00%0.28%0.55%0.83%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Improper Access Control in Mattermost Server versions 9.5.x before 9.5.2, 9.4.x before 9.4.4, 9.3.x before 9.3.3, 8.1.x before 8.1.11 lacked proper access control in the /api/v4/users/me/teams endpoint allowing a team admin to get the invite ID of their team, thus allowing them to invite users, even if the "Add Members" permission was explicitly removed from team admins.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 8.1.0&&< 8.1.118.1.11go get github.com/mattermost/mattermost/server/v8@v8.1.11
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.5.0&&< 9.5.29.5.2go get github.com/mattermost/mattermost/server/v8@v9.5.2
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.4.0&&< 9.4.49.4.4go get github.com/mattermost/mattermost/server/v8@v9.4.4
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.3.0&&< 9.3.39.3.3go get github.com/mattermost/mattermost/server/v8@v9.3.3

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 9.5.0 && < 9.5.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost/server/v8, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost/server/v8 to 8.1.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29221 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Improper Access Control in Mattermost Server versions 9.5.x before 9.5.2, 9.4.x before 9.4.4, 9.3.x before 9.3.3, 8.1.x before 8.1.11 lacked proper access control in the `/api/v4/users/me/teams` endpoint allowing a team admin to get the invite ID of their team, thus allowing them to invite users, even if the "Add Members" permission was explicitly removed from team admins.
O3 Security · Impact-Aware SCA

Is CVE-2024-29221 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-29221: server — Fixed in 8.1.11