CVE-2024-29156 — yaql
MEDIUMCVE-2024-29156 is a medium-severity (CVSS 6.5) CWE-116 vulnerability in yaql. A fix is available for yaql — see the affected versions and patch details below.
Information leakage in YAQL
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29156.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
yaqlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In OpenStack Murano through 16.0.0, when YAQL before 3.0.0 is used, the Murano service's MuranoPL extension to the YAQL language fails to sanitize the supplied environment, leading to potential leakage of sensitive service account information.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | yaql | all versions | 3.0.0pip install --upgrade 'yaql==3.0.0' |
Affected Products
muranoopenstackyaqlopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yaql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update yaql to 3.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29156 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 16.2 | openstack-tripleo-common-0:11.7.1-2.20230809225405.e189622.el8ost | RHSA-2024:4053 |
| Red Hat OpenStack Platform 17.1 for RHEL 8 | openstack-tripleo-heat-templates-0:14.3.1-17.1.20231103003748.2.el8ost | RHSA-2024:1930 |
| Red Hat OpenStack Platform 17.1 for RHEL 9 | openstack-tripleo-heat-templates-0:14.3.1-17.1.20231103010826.2.el9ost | RHSA-2024:1931 |
Frequently Asked Questions
Is CVE-2024-29156 in your dependencies?
Find it across PyPI, including transitive dependencies.