CVE-2024-29029 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in github.com/usememos/memos. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/usememos/memos — see the affected versions and patch details below.
memos vulnerable to an SSRF in /o/get/image
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29029.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/usememos/memosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
memos is a privacy-first, lightweight note-taking service. In memos 0.13.2, an SSRF vulnerability exists at the /o/get/image that allows unauthenticated users to enumerate the internal network and retrieve images. The response from the image request is then copied into the response of the current server request, causing a reflected XSS vulnerability. Version 0.22.0 of memos removes the vulnerable file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/usememos/memos | all versions | 0.22.0go get github.com/usememos/memos@v0.22.0 |
Affected Products
memosusememosResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/usememos/memos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/usememos/memos to 0.22.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29029 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2024-29029
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-29029 -u https://target- Template
- Memos 0.13.2 - Cross-Site Scripting & SSRF
- Severity
- medium
- Impact
- Attackers can inject malicious scripts and perform SSRF attacks, compromising user data and accessing internal resources.
- Remediation
- Update Memos to version 0.13.3 or later.
Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-29029 in your dependencies?
Find it across Go, including transitive dependencies.