CVE-2024-28718 is a medium-severity (CVSS 6.3) CWE-367 vulnerability in magnum. A fix is available for magnum — see the affected versions and patch details below.
OpenStack magnum vulnerable to time-of-check to time-of-use (TOCTOU) attack
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28718.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magnum🐍magnum🐍magnum🐍magnumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | magnum | all versions | 14.1.2pip install --upgrade 'magnum==14.1.2' |
| 🐍PyPI | magnum | ≥ 17.0.0.0rc1&&< 17.0.2 | 17.0.2pip install --upgrade 'magnum==17.0.2' |
| 🐍PyPI | magnum | ≥ 16.0.0.0rc1&&< 16.0.2 | 16.0.2pip install --upgrade 'magnum==16.0.2' |
| 🐍PyPI | magnum | ≥ 15.0.0.0rc1&&< 15.0.2 | 15.0.2pip install --upgrade 'magnum==15.0.2' |
Affected Products
magnumopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magnum, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magnum to 14.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28718 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-28718 in your dependencies?
Find it across PyPI, including transitive dependencies.