CVE-2024-28188 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in jupyter-scheduler. A fix is available for jupyter-scheduler — see the affected versions and patch details below.
jupyter-scheduler's endpoint is missing authentication
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28188.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
jupyter-scheduler🐍jupyter-scheduler🐍jupyter-scheduler🐍jupyter-schedulerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
jupyter_scheduler is missing an authentication check in Jupyter Server on an API endpoint (GET /scheduler/runtime_environments) which lists the names of the Conda environments on the server. In affected versions, jupyter_scheduler allows an unauthenticated user to obtain the list of Conda environment names on the server. This reveals any information that may be present in a Conda environment name.
This issue does not allow an unauthenticated third party to read, modify, or enter the Conda environments present on the server where jupyter_scheduler is running. This issue only reveals the list of Conda environment names.
Impacted versions: >=1.0.0,<=1.1.5 ; ==1.2.0 ; >=1.3.0,<=1.8.1 ; >=2.0.0,<=2.5.1
Patches
jupyter-scheduler==1.1.6jupyter-scheduler==1.2.1jupyter-scheduler==1.8.2jupyter-scheduler==2.5.2
Workarounds
Server operators who are unable to upgrade can disable the jupyter-scheduler extension with:
jupyter server extension disable jupyter-scheduler
References
If you have any questions or comments about this advisory we ask that you contact AWS/Amazon Security via our vulnerability reporting page [1] or directly via email to [email protected]. Please do not create a public GitHub issue.
[1] Vulnerability reporting page: https://aws.amazon.com/security/vulnerability-reporting
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | jupyter-scheduler | ≥ 1.0.0&&< 1.1.6 | 1.1.6pip install --upgrade 'jupyter-scheduler==1.1.6' |
| 🐍PyPI | jupyter-scheduler | ≥ 1.2.0&&< 1.2.1 | 1.2.1pip install --upgrade 'jupyter-scheduler==1.2.1' |
| 🐍PyPI | jupyter-scheduler | ≥ 1.3.0&&< 1.8.2 | 1.8.2pip install --upgrade 'jupyter-scheduler==1.8.2' |
| 🐍PyPI | jupyter-scheduler | ≥ 2.0.0&&< 2.5.2 | 2.5.2pip install --upgrade 'jupyter-scheduler==2.5.2' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jupyter-scheduler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update jupyter-scheduler to 1.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28188 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-28188 in your dependencies?
Find it across PyPI, including transitive dependencies.