CVE-2024-28181 is a high-severity (CVSS 8.1) CWE-74 vulnerability in @turbo-boost/commands. A fix is available for @turbo-boost/commands — see the affected versions and patch details below.
Arbitrary method invocation turbo_boost-commands
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28181.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@turbo-boost/commandsnpmDescription
Impact
TurboBoost Commands has existing protections in place to guarantee that only public methods on Command classes can be invoked; however, the existing checks aren't as robust as they should be. It's possible for a sophisticated attacker to invoke more methods than should be permitted depending on the the strictness of authorization checks that individual applications enforce. Being able to call some of these methods can have security implications.
Details
Commands verify that the class must be a Command and that the method requested is defined as a public method; however, this isn't robust enough to guard against all unwanted code execution. The library should more strictly enforce which methods are considered safe before allowing them to be executed.
Patches
Patched in the following versions.
- 0.1.3
- 0.2.2
Workarounds
You can add this guard to mitigate the issue if running an unpatched version of the library.
class ApplicationCommand < TurboBoost::Commands::Command
before_command do
method_name = params[:name].include?("#") ? params[:name].split("#").last : :perform
ancestors = self.class.ancestors[0..self.class.ancestors.index(TurboBoost::Commands::Command) - 1]
allowed = ancestors.any? { |a| a.public_instance_methods(false).any? method_name.to_sym }
throw :abort unless allowed # ← blocks invocation
# raise "Invalid Command" unless allowed # ← blocks invocation
end
end
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @turbo-boost/commands | all versions | 0.1.3npm install @turbo-boost/commands@0.1.3 |
| 📦npm | @turbo-boost/commands | ≥ 0.2.0&&< 0.2.2 | 0.2.2npm install @turbo-boost/commands@0.2.2 |
| 💎RubyGems | turbo_boost-commands | all versions | 0.1.3bundle update turbo_boost-commands --conservative |
| 💎RubyGems | turbo_boost-commands | ≥ 0.2.0&&< 0.2.2 | 0.2.2bundle update turbo_boost-commands --conservative |
Affected Products
turboboost commandsturboboost_commands_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @turbo-boost/commands, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @turbo-boost/commands to 0.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28181 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-28181 in your dependencies?
Find it across npm, RubyGems, including transitive dependencies.